1

I am trying to migrate data from magento 1 to maganto 2. Both sites are on different server. So when I try to migrate by below command :

sudo php /var/www/m2.gocleaning.nl/bin/magento migrate:settings -r /var/www/siteurl/vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.7/config.xml

it is showing error in the image. Error

FYI : I also can't connect to mysql remotely by using

mysql -u remote -h 176.9.9.14 -p

It is also giving connection timed out error. Tried this solution : Link

One thing I want to confirm should I have to grant privleges on remote database or on local database?

Please help me to sort out this issue ASAP.

3 Answers 3

0

It looks like you ran out of space on your MySQL partition. Check your utilization and allocate some memory.

4
  • on the same server it is working fine but when i try to access from another server it is giving error
    – Charanjeet
    Feb 7, 2019 at 9:59
  • on it's own server it is working fine but when i try to access from another server it is giving error
    – Charanjeet
    Feb 7, 2019 at 10:12
  • user name and password correct? Also, does the user have correct privileges?
    – Greg
    Feb 7, 2019 at 10:15
  • One thing I want to confirm that if I want to access m1 db from another server then where I have to run grant privilege command. And what will be the user name to grant.
    – Charanjeet
    Feb 7, 2019 at 10:42
0

If you can't access your remote MySQL server using the console command, the remote server might not have remote access enabled.

Please check this answer for details -> https://stackoverflow.com/questions/31897406/pdoexception-sqlstatehy000-2002-connection-timed-out-on-my-local-computer

7
  • I have tried all the steps given in your link but no luck
    – Charanjeet
    Feb 7, 2019 at 11:09
  • is there any logs that will provide me why I can't access remote database
    – Charanjeet
    Feb 7, 2019 at 11:09
  • Did you check the firewalls between both server? Is a tcp connection for the port you are using allowed? For database logs location and if logging is enabled check the configuration of MySQL.
    – HelgeB
    Feb 7, 2019 at 11:12
  • Just to get sure: the my.cnf file of your remote server contains the lines bind-address = 176.9.9.14 and # skip-networking (this one either commented out or removed)
    – HelgeB
    Feb 7, 2019 at 11:18
  • bind-address should be on 176.9.9.14 server or other server.
    – Charanjeet
    Feb 7, 2019 at 12:11
0

If this question is not related with migration and to set up a remote MySql database for Magento 2, you must follow the guideline documentation given by Magento here.

https://devdocs.magento.com/guides/v2.3/install-gde/prereq/mysql_remote.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.