1

I am extremely new and undereducated with Ubuntu. I am trying to install Magento using composer and getting below error:

  Problem 1
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
    - magento/product-community-edition 2.3.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  Problem 2
    - Installation request for magento/magento2-functional-testing-framework 2.3.9 -> satisfiable by magento/magento2-functional-testing-framework[2.3.9].
    - phpunit/phpunit 6.5.0 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.1 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.10 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.11 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.12 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.13 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.14 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.2 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.3 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.4 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.5 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.6 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.7 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.8 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - phpunit/phpunit 6.5.9 requires sebastian/diff ^2.0 -> satisfiable by sebastian/diff[2.0.1].
    - Conclusion: don't install sebastian/diff 2.0.1
    - Installation request for phpunit/phpunit ~6.5.0 -> satisfiable by phpunit/phpunit[6.5.0, 6.5.1, 6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9].

I have solved the first problem related to curl extension. However, problem 2 has me stumped. No idea where to go from here. Any help will be appreciated.

  • Are you currently trying to install magento/magento2-functional-testing-framework at the same time? What steps did you take before encountering this error message? – Kristof at Fooman Feb 7 at 1:15
  • 1
    if you are beginner, first try to install with GUI, download magento from magento.com/tech-resources/download and install it.It will give you all error before install. – Pawan Feb 7 at 4:15
  • have you retry to install magento after solving first problem? – Satish Dubariya Feb 7 at 5:06
  • you have to Install PHP curl & Make you sure your PHP version compatible with Magento 2.3 – Birjitsinh Zala Feb 7 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.