0

I have installed on my Magento 2.3 server and an annotation has arrived for me to install Elasticsearch. This is my system:

  • Ubuntu 18.04
  • Nginx 1.14.0
  • MySQL 5.7.25

I have followed these instructions:

https://www.elastic.co/guide/en/elasticsearch/reference/5.2/deb.html

And this is the error that I have:

enter image description here

3
  • 1
    try this digitalocean.com/community/tutorials/…
    – Akash
    Commented Feb 6, 2019 at 10:48
  • Magento Open Source 2.3.x supports the following Elasticsearch versions: Elasticsearch 5.2 Elasticsearch 2.x Commented Feb 6, 2019 at 11:02
  • @Suman-PHP4U ok but, How do I solve my problem?
    – Despotars
    Commented Feb 6, 2019 at 11:04

1 Answer 1

0

For OS relates issues check below post

https://stackoverflow.com/questions/29447434/elasticsearch-memory-problems

Either give more memory to your VM, or change Elasticsearch JVM settings /etc/elasticsearch/jvm.options and lower the values of the following parameters: -Xms512m -Xmx512m

3
  • My server is a digital ocean server with 2G of memory...
    – Despotars
    Commented Feb 6, 2019 at 11:07
  • If you check the error log it says "There is insufficient memory for the Java Runtime Environment to continue" so you need to increase the JVM memory, talk to there customer care Commented Feb 6, 2019 at 11:08
  • You can change the allocations in the config. On a dev server I only allow 200MB
    – Anthony
    Commented May 28, 2019 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.