0

I was able to run php bin/magento setup:static-content:deploy command, but after changing the permissions of the folders this is giving error:

There is no directory in bin folder. I have just installed the fresh magento 2.3.

Please help me what I am missing or doing wrong.
3

Go to the root folder of your Magento project and run the following commands :

  1. sudo php bin/magento setup:upgrade
  2. sudo php bin/magento setup:di:compile
  3. php bin/magento setup:static-content:deploy -f
  4. sudo php bin/magento cache:clean
  5. sudo chmod -R 0777 pub var generated

file permission change by ssh and run below command

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
sudo chmod -R 0777 pub var generated

  • now my site is showing only text both frontend and backend. I have tried above all commands but not working. – Charanjeet Feb 4 at 11:13
  • Showing 404 error on all css files and js files – Charanjeet Feb 4 at 11:13
  • update screenshot in question also you can run command in magento directory – Rakesh Donga Feb 4 at 11:14
  • Tried all commands but still showing on text no css,js – Charanjeet Feb 4 at 11:21
  • still showing text only – Charanjeet Feb 4 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.