1

I am unable to change Locale options in Stores >> Configuration >> General tab Configurations. After saving the configurations it shows 'You saved the configuration.' but there is no change.

Flushed the cache, reindexed but still no change. Checked console but no error in console.

screenshot

update 1 Disabled all third party extensions but it still didn't worked.

update 2 Can't save any general configuration in Default Config store view.

8
  • which option to you have change? Feb 4, 2019 at 10:57
  • Timezone and Locale both.
    – chanchal
    Feb 4, 2019 at 11:00
  • please clean cache and remove pub/static/ folder Feb 4, 2019 at 11:08
  • disable all your third party extension or custom module, and check if it will work again. if it works , enable your third party or custom module one by one to check which is causing the issue.
    – fmsthird
    Feb 4, 2019 at 11:52
  • Disabled all third party extensions , but still didn't worked.
    – chanchal
    Feb 5, 2019 at 4:45

2 Answers 2

0

I got the same issue and resolved through this page, If you are still looking for the issue just checkout this page : https://www.mageplaza.com/kb/how-setup-locale-state-country-magento-2.html

0

It's happening because your store is in production mode, change it to developer mode to allow this change.

It's not a bug, it's a feature to avoid adding a location that you don't have the static files compiled to support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.