0

After having to download the theme into my Magento root I run command php bin/magento setup: upgrade and I meet that error:

Magento supports 7.0.2, 7.0.4, and 7.0.6 or later. Please read http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements.html

I don't understand why this error comes, maybe because my PHP version is 7.2.11..
Please help me .thanks.

3
  • What version of Magento are you running?
    – arjus
    Commented Feb 1, 2019 at 22:27
  • yeah try changing your PHP version to 7.1.x
    – fmsthird
    Commented Feb 1, 2019 at 23:54
  • magento version 2.3
    – chou marco
    Commented Feb 2, 2019 at 17:31

1 Answer 1

0

Your cli PHP version may be different than the one used in HTTP requests (configured in Apache / Nginx)

What you need to do is first check your cli PHP version by running php -v and if it's less than 7.0 you need to change it. Depending on your operating system, there are different methods to do that.

For example, on Ubuntu, you need to run the following command: sudo update-alternatives --set php /usr/bin/php7.0

On Windows, it depends on what WAMP application you are using. You should check the application documentation

4
  • my php CLI version is 5.6 ... im working in local and i use laragon
    – chou marco
    Commented Feb 2, 2019 at 17:33
  • Ok, and have you tried changing the CLI PHP version?
    – Alex Dinca
    Commented Feb 4, 2019 at 8:46
  • yes of course, i have to upgrade my CLI PHP version , can you help me?
    – chou marco
    Commented Feb 4, 2019 at 11:05
  • ok, so if you run php -v in your console, and get a version > 7.0, do you still have issues running php bin/magento setup:upgrade ? If yes, what is the new issue?
    – Alex Dinca
    Commented Feb 4, 2019 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.