0

In Magento 2,I can't enable/disable cache In System -> Cache Management, the two options are missing from the dropdown menu. what did wrong?

It's in Default mode.

enter image description here

Anyone has idea on this?

  • 1
    Currently your mode is set to production so only Refresh Cache option will be there in drop down and thats why you are not able to see Enable/Disable dropdown of cache. – HIren Kadivar Feb 1 at 8:08
  • regardless of mode it should show up. Have you tried flush cache storage or the other one option? – magefms Feb 1 at 8:15
  • @Hlren can you check on my above question i have mentioned that i am on default mode not on production? – Charul Tyagi Feb 1 at 9:29
  • Did you resolve your issue? – Shoaib Munir Feb 6 at 9:58
  • no @ShoaibMunir – Charul Tyagi Feb 6 at 11:21
0

Set developer mode, clear cache and try again

php bin/magento deploy:mode:set developer --skip-compilation
php bin/magento cache:clean
php bin/magento cache:flush

Magento modes details: https://devdocs.magento.com/guides/v2.2/config-guide/bootstrap/magento-modes.html#mode-production

  • The link directs us to the same page. :) – Siarhey Uchukhlebau Feb 1 at 9:06
  • Thank @SiarheyUchukhlebau. Answer updated :) – Shoaib Munir Feb 1 at 9:09
0

Yeah. You are in production or default mode. So it doesn't show enable and disable cache option.

So please change deploy mode into developer mode and now you can change cache enable or disable

php bin/magento deploy:mode:set developer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.