0

I migrated my Magento 2 test site to the actual site (which was already running Magento 2 with older data) and noticed, that everything seems to work - only "admin_adminkey" and "privacy-policy-cookie-restriction-mode" do not work. Product pages as well as cms pages seem to work without any issue. I also redirected non-existing page requests to "home" - so typing random stuff after / also gets me to home - as expected. This in term means, that "admin_adminkey" and "privacy-policy-cookie-restriction-mode" is treated "specially" because those are not redirected to "home" but just give a plain:

404 Not Found
-------------
    nginx

The proxy_error_log shows:

2019/01/31 16:51:34 [error] 851#0: *15809 "/var/www/vhosts/mydomain.eu/httpdocs/privacy-policy-cookie-restriction-mode/index.html" is not found (2: No such file or directory), client: xxx.xxx.xxx.xxx, server: mydomain.eu, request: "GET /privacy-policy-cookie-restriction-mode/ HTTP/2.0", host: "www.mydomain.eu", referrer: "https://www.mydomain.eu/"

2019/01/31 16:52:36 [error] 851#0: *15809 "/var/www/vhosts/mydomain.eu/httpdocs/admin_mykey/index.html" is not found (2: No such file or directory), client: xxx.xxx.xxx.xxx, server: mydomain.eu, request: "GET /admin_mykey/ HTTP/2.0", host: "www.mydomain.eu"

The server is running Plesk 17 and the test-site, which is just living in a subdomain of the same domain works.

I tried re-deploying static files, runing upgrade, clearing cache per console as well as deleting all the var/cache, var/composer_home, var/page_cache, var/view_preprocessed and resetting all permissions per this post: Magento 2 folder/file permissions but this does not change my situation.

The migration process was:

  1. Dump source (new) MagentoDB, clear out target (old) MagentoDB.
  2. Populate target MagentoDB with said dump.
  3. Change the core_config_data table entries web/unsecure/base_url and web/secure/base_url to the new domain.
  4. Delete all target MagentoFiles.
  5. Copy all source MagentoFiles to the target directory (and make sure the hidden . files are copied as well).
  6. Change the credentials in app/etc/env.php
  7. Delete cache directories and clear cache per console.

This made the frontend look "ok" except the cookie info page and the admin backend was also not accessible. Afterwards I tried many things suggested out there - but as redirects are working and a Magento of the same version was running just before I transfered the data (just with less extensions and older data) I am at a loss on what to do next / how to debug this.

Any hints are appreciated! Thanks, Tamashii

0

The problem was in the end related to the server. The Plesk panel respectively. Seems like Apache worked only "partially" on the .htaccess files and URLs with an ending / like https://www.mydomain.eu/some_cms_page/ did not work whereas https://www.mydomain.eu/some_cms_page worked as intended.

I disabled "Smart static files processing" (Proxy mode enabled) and switched from PHP Settings: "run PHP as FPM application served by Apache" to "run PHP as FastCGI application served by Apache" - and this worked again.

Interestingly: After switching "Smart static files processing" back on and going back to PHP FPM served by Apache - it still works.

My personal conclusion is, that there was some kind of Error leading Nginx to resolve part of the pages and after changing the configs in Plesk and changing it back again (which caused the respective configs to be re-written), the newly written configs were correct again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.