1

Hi I have previously working magento site.I just uninstall and reinstalled the php.Now site is giving a blank page but in the magento 1.9 index.php die is working but not showing any error. I have tried display_errors and other things.Please help me to solve the problem ASAP. Also there is not any error log. Can I find some error log. Thanks.

5
  • you can check error log Jan 31, 2019 at 5:19
  • Which PHP version you are using for Magento 1.9? Jan 31, 2019 at 5:19
  • php 5.6. I can't see any error in logs.
    – Charanjeet
    Jan 31, 2019 at 5:22
  • BTW Where can I check ther error?
    – Charanjeet
    Jan 31, 2019 at 5:23
  • @Charanjeet check my answer Jan 31, 2019 at 5:26

2 Answers 2

-1

you can add below code in index.php in top and after check it

ini_set('error_reporting', E_ERROR);
register_shutdown_function("fatal_handler");
function fatal_handler() {
    $error = error_get_last();
    echo("<pre>");
    print_r($error);
}
11
  • Array ( [type] => 1 [message] => Class 'SimpleXMLElement' not found [file] => /var/www/gocleaning.nl/includes/src/__default.php [line] => 24707 )
    – Charanjeet
    Jan 31, 2019 at 5:30
  • this is the output
    – Charanjeet
    Jan 31, 2019 at 5:31
  • run below command : apt install php5.6-xml After it reload and restart apache2 service : service apache2 reload service apache2 restart Jan 31, 2019 at 5:33
  • i am using nginx server and centos 7. What install php-xml will do?
    – Charanjeet
    Jan 31, 2019 at 5:35
  • @Charanjeet try sudo apt-get install php-xml please check this linnk ajayogal.wordpress.com/2017/06/05/… Jan 31, 2019 at 5:41
1

You will find log files

var/log

In this folder there are exception.log and system.log files

Plus there is report folder as well in which you get the error in report number wise file

I hope this will find. if you still have any difficulty please let me know

8
  • No there is not any helpful error all are old errors
    – Charanjeet
    Jan 31, 2019 at 5:28
  • @Charanjeet you ask for magento 1.9 errors log. so I gave you the path of errors log. if you still haven't got any error then try to add this code error_reporting(E_ALL); ini_set('display_errors', 1); in your magento code index.php file Jan 31, 2019 at 5:31
  • I already tried this but no luck.
    – Charanjeet
    Jan 31, 2019 at 5:32
  • @Charanjeet brother oh I got you. You should also enable the error log from admin backend check this tutorial magestore.com/magento-basic-setting/… Jan 31, 2019 at 5:36
  • Once you done please let me know Jan 31, 2019 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.