0

I'm working on migrating my site over to a new server and everything is up and running, except when I go to add an item into stock it doesn't work.

I am not getting a Magento error nor is it showing an error in my error log. There is also no errors in the console when I inspect the page. I have tried clearing my cache, and this error exists on different browsers. Where should I look next to get this fixed?

Edit: there are no DB errors that I can see, and the items are in stock

0

Potentially 2 things.

First possibility:

The current configuration has different cookie path/domain, so your user session is never maintained - which results into an empty cart even right after adding an item.

You can check/verify this by using Chrome DevTools, navigating to "Application" tab and then Cookies in the left menu. Find one that has the name "frontend" and verify that the "Domain" and "Path" columns for that are correct.

If not - this can be fixed in System configuration: Web -> Session Cookie Management-> Cookie Path / Cookie Domain or by making edits directly in the database within core_config_data table.

Second possibility:

It is likely that your 1.7 has had patches installed which makes it so form_keys are required for forms to accept your post data.

To verify this go to the product page in front-end and check the page source and verify that you have a form_key input within your add to cart form. The input field should look like this:.

<input name="form_key" type="hidden" value="......." />

If you can not find this make sure you add it into your add to cart form via XML layout or directly into phtml by adding:

<input name="form_key" type="hidden" value="<?php echo Mage::getSingleton('core/session')->getFormKey() ?>" />
  • That was super helpful! I tried these. The issue did turn up to be a database issue. I ended up reloading the database and that fixed it. – Morgan Smith Jan 31 '19 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.