0

[29-Jan-2019 11:02:16 UTC] PHP Warning: include_once(): Failed opening '/home/prin/public_html/includes/src/Varien_Autoload.php' for inclusion (include_path='/home/prin/public_html/includes/src:.:/opt/alt/php54/usr/share/pear:/opt/alt/php54/usr/share/php') in /home/prin/public_html/app/Mage.php on line 37 [29-Jan-2019 11:02:16 UTC] PHP Fatal error: Class 'Varien_Autoload' not found in /home/prin/public_html/app/Mage.php on line 54

1 Answer 1

0

You have enabled compilation mode , thats way you see those errors. Its suggested to experiment on a non-production system, as errors during compilation can white screen the store , like it may be happened to you . After compiling the classes, Magento immediately put`s itself into “read from the compiled code” mode .

Disable compilation: Go into

includes/config.php and comment this line

-#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');

To get rid of the error you need to disable the compilation in production , and clear the include directory created during compilation includes/src.

php -f shell/compiler.php – clear

4
  • these two lines already exists there define ('COMPILER_INCLUDE_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'src'); #define('COMPILER_COLLECT_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'stat');
    – rajat
    Commented Jan 30, 2019 at 8:37
  • ok so just comment the first line Commented Jan 30, 2019 at 8:46
  • thanks for your answer . it solved my problem
    – rajat
    Commented Jan 30, 2019 at 8:51
  • @rajat Glad it is solved , can you accept it as an answer :) . Commented Jan 30, 2019 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.