0

Basically, my problem is that I need to get the minimal_price of an configurable product in category view. Previously, this worked by using

$_product = $this->getProduct();

$_product->getMinimalPrice();

However, it doesn't work anymore. I noticed, that when it still worked dumping $_product would contain 'minimal_price'. Now, this is not the case anymore. Does anyone know what the reason could be?

  • Did you enable flat products? – Melvyn Jul 3 '14 at 22:35
1

Thanks for the input from everyone. Melvyn was right, flat products weren't enabled. I think I had it once enabled but the index wasn't refreshed. Thinking about it that was really obvious but until I found out the page became so slow because minimal_price was missing took forever. So thanks a lot, Melvyn!

0

This might help:

$tier_price = end($_product->getTierPrice());
echo $tier_price['price'];

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.