I'm using Magento 2.3. How can I fix Admin>Sales>Orders?
The list is not showing. I have orders but it's not showing.

Please help!!

  • Did you have run indexer command? – Suresh Chikani Jan 25 at 19:43
  • yes! showing We couldn't find any records. please help @SureshChikani – niceonelee Jan 25 at 19:48

You can check with below option, may be it will help to you.

Disable Asynchronous indexing from Store > Configuration > Advance > Developer > Grid Settings

Note: The Developer tab and options are only available in Developer mode.

Updates : Asynchronous order data processing.

There can be times when intensive sales on a storefront occur at the same time that Magento is performing intensive order processing. You can configure Magento to distinguish these two traffic patterns on the database level to avoid conflicts between read and write operations in the corresponding tables. You can store and index order data asynchronously. Orders are placed in temporary storage and moved in bulk to the Order Management grid without any collisions. You can activate this option from Stores > Configuration > Advanced > Developer > Grid Settings > Asynchronous indexing.

You can get more information : DevDocs

  • Thank you so much! Can you tell me the reason? but this is not more quicly for system? – niceonelee Jan 25 at 20:16
  • You can just check after disabling this option. Is working or not. – Suresh Chikani Jan 25 at 20:39
  • yes, it is working. but why when i after enabled it not showing order list. – niceonelee Jan 25 at 20:51
  • Check my updated answer. – Suresh Chikani Jan 25 at 21:27
  • Yes,but why i getting this issue? i dont understand , thank you! – niceonelee Jan 26 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.