enter image description here

And Error response is

{"schemaValidationMessages":[{"level":"error","message":"Can't read from file http://<SITE_URL>/rest/default/schema?services=all"}]}
  • i think its working well with magento 2.3 i have just tested magento.amanweb.in/rest/default/schema?services=all however if not working for you please check file permission ones. – Aman Alam Jan 22 '19 at 7:06
  • Yes, I've already checked it's working in 2.3 but not working in 2.2.6. Event I had tried using 777 file permission already. I am looking solution for version 2.2.6. – Mehul Soni Jan 23 '19 at 6:18

The given url only supports the store code default.

In the latest version of magento 2 it is possible to change through the url parameter store.

If your version doesn’t support it yet just overwrite the swagger template file and replace default with your store code.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.