3

There are some products in my store that are not displayed in search results, when searching by product name. Same products are found in search results when searching by sku.

I have tried re-indexing, re-assigning them to websites/stores.
Product name is a searchable attribute.

Also I have traced that searching a particular product by name, returns a row from catalogsearch_result table.

SELECT * FROM `catalogsearch_result` WHERE `query_id` = 2865 

In the SQL result, the product_id is correct, but still product is not displaying in results.

Any ideas?

----- UPDATE -----

  • Product name is 'Forever'
  • Product is found when searching string is 'orever', 'rever', 'ever'
  • But product is not found when searching the full name 'Forever'
  • 1
    A very low level analysis method would be to enable general logging on the MySQL database, fire the search, disable it, then take a look at the generated SQL statement and manually run it, removing parts until the product(s) are returned, then check why the parts remove the products from the SQL resultset. – 0xCAFEBABE Jan 22 at 14:51
  • I've had problems like that. Usually these are attributes that are missing. Try saving one of these products by admin and check if it appears in the search. Try to check the attributes too. If it does, you'll have to analyze which attributes are missing and set it on problematic products. – Douglas Ianitsky Jan 22 at 15:01
  • Can you check your admin configuration settings System -> configuration -> catalog search settings – Amit Naraniwal Jan 24 at 10:40
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – Jai Jan 24 at 11:01
0

This may not be the best answer but something that has worked for me in the past when a product isn't showing up in search:

  1. Go to Manage Products and checkmark your product.
  2. Next, "Update Attributes" from the dropdown above the grid.
  3. On the Update Attributes page, click to the Websites tab and re-associate with the proper website by checking the checkbox under Add Products To Website.
  4. Click save and rebuild the Search Index.

Original suggestion here: https://magento.stackexchange.com/a/68076/35364

  • thank you for your answer, but unfortunately it didn't work – zekia Jan 22 at 15:19
  • Please check Admin > Catalog > Attributes > Manage Attributes : Name attributes is Set to Yes in Search please check this screenshot : prnt.sc/md2tcx – hardik Jan 28 at 5:24
  • name attribute is enabled for search. As I mentioned in question, product is listed in results by searching part of it's name. – zekia Jan 28 at 12:21
0

Does any custom/third party module install related to search feature? If not then please check the following admin settings:

  • Open the Catalog Search section, and continue with following:

  • In the Minimal Query Length field, enter the number to set mininum characters that can be submitted in a query

  • In the Maximum Query Length field, enter the number to set maximum characters that can be submitted in a query

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.