I am using XAMPP with php set up with memory_limit 2GB and max_input_vars set to 10000.

Is there anything else I can do to speed up performance of Magento 2 on windows?

  • Try enabling cache if it's not already enabled. Commented Jan 16, 2019 at 5:13
  • The setup is for development purpose, I would rather not have to clear cache every time a change need to be reflected. Commented Jan 16, 2019 at 5:15
  • Yeah i also had same thought as I do same for Magento 1 but Magento 2 is dead slow in local machine. So instead waiting for page load, I felt its good to clear cache sometimes. Try once if helps else you can always disable cache :) Commented Jan 16, 2019 at 5:18
  • Try these works for me and better speed bitnami.com/stack/magento/installer Commented Jan 16, 2019 at 5:29
  • @AkhilGupta, but still for frontend having to deploy content for compiling less is a real pain. Commented Jan 16, 2019 at 5:31

2 Answers 2


The problem may be Xdebug in xampp\php\php.ini. Here're some solutions found around the web:

  1. Run XAMPP as adminisrator and restart server.
  2. In xampp/apache/conf/httpd.conf, replace localhost with and restart server.
  3. In Windows/System32/drivers/etc/hosts, add “” & “ localhost” and restart Window.
  4. In Windows/System32/drivers/etc/hosts, un-comment “ localhost” and restart Window.
  5. In php.ini, uncomment zend_extension = "C:\xampp\php\ext\php_eaccelerator_ts.dll" and restart server.
  6. In php.ini, set xdebug.remote_enable=0.
  7. In php.ini, set remote_host="localhost".
  8. In php.ini, set xdebug.profiler_enable=0.
  9. In php.ini, comment out all Xdebug statements.
  10. If you using any antivirus on window pc, switch off the antivirus realtime scan (or add exclusion for XAMPP folders). Note: don't forget to restart the computer after the antivirus setting update (without that, the change couldn't take effect properly)
  11. Try PHP7 under XAMPP

In windows 10 you need to make real-time protection off under Windows Security, this will increase the performance in Windows

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.