1

I have to get helped in some parts of my website with a friend who is a developer, so he asked me the access to the backend.

Being that I don't want to give the full access, I have created a new user and a new role just for him.

When I started to customize the resources, I have selected everything without the Permissions > User section.

And then came the issue: opening the backend with the new user, I don't see some sections. They just disappeared.

Going back to the resources tree, I discovered that they never been there, so I can't select the sections. But if I select Resource access > All, the sections are shown again in the left backend panel.

How do I solve this? Thanks in advance!

Edit: These are some pics, as you can see if the admin has full roles I can see the Porto Icon (in this example)

Pic 1

But if I manage admin roles, putting custom and deflagging in that case the User permissions

Pic 2

I lose the Porto icon section, as you can see.

Pic 3

I think that probably it happens because when I choose "Select all" Magento selects all the sections - even the ones that I can't see in the Role Resources tree, so if I put "Custom" I am not able to select everything because I don't see some sections.

  • can you post a screenshot or 2? I don't really understand what's happening – Marius Jan 15 at 13:17
  • Are the missing resources related to some custom module or Magento's core module? If the resources are from custom module, then there may be problem in defining acl for the module. – Mohit Kumar Arora Jan 15 at 13:39
  • ok, added some pics. Thanks everyone for the reply and let me know if now you understand better the question, thank you! – myrdipiombo Jan 15 at 13:42
  • @MohitKumarArora sorry I read only now. Yes the resources are from custom module, how do I define acl? – myrdipiombo Jan 15 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.