I have a Magento 2.3.0 website that works correctly but suddenly (maybe after a products import, but also other various activities were done) when I try to call ANY (reindex, deploy...) command of "bin/magento" it returns me:

An exception was raised while creating "Request"; no instance returned

I tried to add more debugging output with -vvv but the error remain the same.

Anyone know what could be the cause or any method to further debug it?

  • I think you need check logs, enable PHP log also. I had this issue and after enabling PHP errors I was able to see error on frontend. Problem was missing version number in setup module table of one module
    – BartZalas
    Commented Jan 11, 2019 at 13:18
  • I have Magento and PHP log and error reporting enabled but it looks like it returns only that exception that looks raised by the call $bootstrapApplication->bootstrap($configuration); of /vendor/magento/framework/Console/Cli.php
    – Riccardo
    Commented Jan 22, 2019 at 17:08

4 Answers 4


The problem might be caused due to the magento / .htaccess file missing under the folder magentoroot/../bin

Also,check the current PHP version in your terminal using below command

php -v

To know the path of the php

whereis php

Based on the Magento version, you need to set the php version.


Set PHP Version 7.2 Your problem is solved.
I have checked and it's working for me.


Try to delete all the cached files with the following command rm -rf cache/* page_cache/* di/* generation/*

and re-run the reindex. If it's a live website, maybe will be worth enabling the maintenance mode before running the command

  • 1
    Tried to clean them but error still occurs.
    – Riccardo
    Commented Jan 11, 2019 at 9:02

Change the PHP version according to your Magento version. it should be working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.