1

Magento 2.1.9 Version Community Edition. My Catalog search page is not displaying any results as show below. enter image description here

So far what has been done as testing.But still not working.

  • Re indexed still not displaying.
  • Removed the custom theme and applied Magento Luma theme still not displaying.
  • Installed ElasticSearch and module still search page not displaying the products.
  • Disabled plugins then also not displaying.
  • The Quantity is greater than 0 for at least more 50 products.
  • In Stock option is checked for products for whom the quantity number is greater than 0.
  • Display in catalog search is checked for product name and sku attributes.

Can please any one help. Had couple of days on this issue still not able to resolve.

URL string is xxx.xxx.com/catalogsearch/result/?q=revo

Any help is appreciated.

  • Hi chris, do you know why it display message like "Test products"? Did you override some file? – Abhishek Panchal Jan 10 at 15:52
  • Please review errors/messages in var/log/ folder – KAndy Jan 10 at 15:58
  • Hi @AbhishekPanchal i have modified the file to check if everything is alright /Magento_CatalogSearch/templates/result.phtml in my custom theme. It does matter even if revert to magento luma theme it is same effect, results does get displayed. – ChrisP Jan 11 at 5:45
  • @KAndy can you be specific please which file in the log i should look for and what should i search for. – ChrisP Jan 11 at 5:51
  • @KAndy thanks your answer it was helpful. The list.phtml that was corrupt, it was given in the system log and i fixed the error. – ChrisP Jan 11 at 8:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.