1

I want to upgrade my Magento from 2.2.7 to 2.3.0.

composer require magento/product-community-edition 2.3.0 --no-update 
composer update 

After typing this in my console i'm getting the following errors:

Problem 1
    - Conclusion: don't install magento/product-community-edition 2.3.0
    - magento/data-migration-tool 2.2.0 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
    - magento/data-migration-tool 2.2.0 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
    - magento/data-migration-tool 2.2.0 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
    - magento/framework 101.0.1 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.2 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.3 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.1 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.2 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.3 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.0 requires colinmollenhour/php-redis-session-abstract ~1.2.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2.2].
    - magento/framework 101.0.0 requires colinmollenhour/php-redis-session-abstract ~1.2.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2.2].
    - magento/framework 101.0.7 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.4 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.5 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.6 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.7 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.4 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.5 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.6 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - magento/framework 101.0.7 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.0].
    - Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.0, v1.3.4].
    - Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.0, v1.3.4].
    - Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.0, v1.2.2].
    - Can only install one of: magento/zendframework1[1.14.1, 1.13.0].
    - magento/product-community-edition 2.3.0 requires colinmollenhour/php-redis-session-abstract ~1.4.0 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.4.0].
    - magento/product-community-edition 2.3.0 requires magento/zendframework1 ~1.14.1 -> satisfiable by magento/zendframework1[1.14.1].
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
    - Installation request for magento/data-migration-tool 2.2.0 -> satisfiable by magento/data-migration-tool[2.2.0].

So what to do or what is the problem?

Getting new errors after trying this: upgrade magento 2.1.13 to 2.3.0

'Problem 1
    - Installation request for magento/data-migration-tool 2.2.0 -> satisfiable by magento/data-migration-tool[2.2.0].
    - magento/product-community-edition 2.3.0 requires colinmollenhour/php-redis-session-abstract ~1.4.0 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.4.0].
    - magento/product-community-edition 2.3.0 requires colinmollenhour/php-redis-session-abstract ~1.4.0 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.4.0].
    - Conclusion: don't install colinmollenhour/php-redis-session-abstract v1.4.0
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].'
2

I can also confirm that after removing the Magento Data Migration Tool I was able to upgrade from 2.2.7 to 2.3.1. Here are the steps:

bin/magento module:disable Magento_DataMigrationTool

bin/magento setup:upgrade

composer remove magento/data-migration-tool

By the way, I used the Magento recommended way for upgrading from 2.2 to 2.3: using the script: https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html

0

After @Charul Tyadi answer i get the following error:

Problem 1
    - Conclusion: don't install magento/framework 102.0.0
    - magento/product-community-edition 2.3.0 requires magento/framework 102.0.0 -> satisfiable by magento/framework[102.0.0].
    - magento/product-community-edition 2.3.0 requires magento/framework 102.0.0 -> satisfiable by magento/framework[102.0.0].
    - Conclusion: don't install magento/framework 102.0.0|install magento/framework 102.0.0
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
  • Solved: Magento Data Migration Tool causes error. After removing it from my composer.json it works... – Marcel Jan 11 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.