0

I am currently trying to Migrate datafrom our Magento 1 site to the Magento 2 site. We've installed the Ubertheme tool and set the details up in the extension.

enter image description here

but every time I try to set up the Databases tab I get the following error:

enter image description here

Both the original website and the new Magento 2 database have the same host (localhost:3306) and as far as I can tell I am using the right credentials. So I'm not sure why this error is happening.

UPDATE:

After speaking to my hosting provider the issue seems to be that, in this case, the extension is reading the Host name as localhost:3306 automatically in both the source and target database fields.

Manually editing the host to read "localhost" and setting the port to "3306" seems to allow connection to the database but the current issue is that I can't connect to the Magento 2 database.

It doesn't seem to be possible to modify the fields in the "Target" database as the field values are detected automatically and cannot be changed.

I have tried modifying the information in the following file:

pub/ub-tool/protected/config/db.php

But this does not seem to affect any of the values in the fields on the interface.

I'm currently in contact with Ubertheme to resolve the issue and will post an answer if/when I have one.

  • Are you trying that on your local system? if not then try it on local system. – Saphal Jha Jan 8 at 16:31
  • Hi. Not sure what you mean by “local”. Both databases are on the same sql server and I even had them in the same web address. The sites are installed on a web hosting company’s server so they aren’t on a local machine. If you could clarify I would appreciate it. Thanks – CJNotts Jan 8 at 20:10
  • I mean to say your instead of using server directly use your computer, setup everything in your computer then try migration. – Saphal Jha Jan 9 at 5:00
  • I’m fairly new to Magento so I’m afraid I wouldn’t be sure how to do this. The sites are set up through a Plesk control panel by our hosting provider. – CJNotts Jan 9 at 6:53
  • I would like you to set it up everything on local as you are new in magento so that will be good for you. – Saphal Jha Jan 9 at 6:56
0

After some back-and-forth between my hosting provider and Ubertheme, we seem to have a solution.

The issue was that, in this case, the extension is reading the Host name as localhost:3306 automatically in both the source and target database fields.

Manually editing the host to read "localhost" and setting the port to "3306" resolves the issue in the "Source" database section.

With regards to the "Target" database, apparently, this Magento 2 instance has a special setting in the MySQL host configuration in the config file at:

app/etc/env.php

In this file there a setting which was as follows:

'host' => 'localhost:3306',

Resetting this to the following seems to have resolved the issue

'host' => 'localhost',

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.