0

I am trying to update Magento 2.2.7 to 2.3.0:

composer require magento/product-community-edition:2.3.0 --no-update
composer update

However a strange error is trown:

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/module-theme 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.0-rc3 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.0-rc2 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.1.0-rc1 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - magento/module-theme 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.16) does not satisfy that requirement.
    - weltpixel/module-google-tag-manager 1.6.4 requires magento/module-theme 100.* -> satisfiable by magento/module-theme[100.2.5, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.6, 100.1.1, 100.1.2, 100.1.3, 100.0.7, 100.1.4, 100.0.8, 100.1.5, 100.1.6, 100.2.0-rc20, 100.2.0-rc21, 100.2.0-rc22, 100.2.0-rc23, 100.2.0-rc30, 100.1.7, 100.0.9, 100.2.0, 100.0.10, 100.2.1, 100.1.8, 100.1.9, 100.2.2, 100.2.3, 100.1.10, 100.2.4, 100.1.11, 100.1.12, 100.2.6, 100.1.13, 100.2.7].
    - weltpixel/module-google-tag-manager 1.6.4 requires magento/module-theme 100.* -> satisfiable by magento/module-theme[100.2.5, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.6, 100.1.1, 100.1.2, 100.1.3, 100.0.7, 100.1.4, 100.0.8, 100.1.5, 100.1.6, 100.2.0-rc20, 100.2.0-rc21, 100.2.0-rc22, 100.2.0-rc23, 100.2.0-rc30, 100.1.7, 100.0.9, 100.2.0, 100.0.10, 100.2.1, 100.1.8, 100.1.9, 100.2.2, 100.2.3, 100.1.10, 100.2.4, 100.1.11, 100.1.12, 100.2.6, 100.1.13, 100.2.7].
    - Can only install one of: magento/module-theme[101.0.0, 100.1.13].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.5].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.0-rc20].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.0-rc21].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.0-rc22].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.0-rc23].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.0-rc30].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.0].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.1].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.2].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.3].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.4].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.5].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.6].
    - Can only install one of: magento/module-theme[101.0.0, 100.2.7].
    - magento/product-community-edition 2.3.0 requires magento/module-theme 101.0.0 -> satisfiable by magento/module-theme[101.0.0].
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
    - Installation request for weltpixel/module-google-tag-manager ^1.6 -> satisfiable by weltpixel/module-google-tag-manager[1.6.4].

My composer.json:

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.2.7",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"require": {
    "magento/product-community-edition": "2.3.0",
    "composer/composer": "@alpha",
    "mageplaza/magento-2-dutch-language-pack": "dev-master",
    "mageplaza/module-core": "^1.3",
    "mollie/mollie-api-php": "^1.9",
    "fooman/pdfcustomiser-m2": "^8.0",
    "myparcelnl/magento": "~2.3.3-beta.2",
    "myparcelnl/sdk": "~v1.3.8",
    "mollie/magento2": "^1.2",
    "weltpixel/module-google-tag-manager": "^1.6",
    "aheadworks/module-onestepcheckout": "1.2.0",
    "wyomind/datafeedmanager": "11.5.2",
    "magepal/magento2-gmailsmtpapp": "^2.5",
    "amasty/shopby": "^2.9"
},
"require-dev": {
    "phpunit/phpunit": "~6.2.0",
    "squizlabs/php_codesniffer": "3.1.1",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.5.0",
    "friendsofphp/php-cs-fixer": "~2.2.0",
    "lusitanian/oauth": "~0.8.10",
    "sebastian/phpcpd": "2.0.4"
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": [
            "app/code/"
        ]
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ],
    "exclude-from-classmap": [
        "**/dev/**",
        "**/update/**",
        "**/Test/**"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "stable",
"extra": {
    "magento-force": "override"
},
"repositories": {
    "wyomind": {
        "type": "composer",
        "url": "https://repo.wyomind.com"
    },
    "aheadworks": {
        "type": "composer",
        "url": "https://dist.aheadworks.com"
    },
    "fooman": {
        "type": "composer",
        "url": "{repo-removed-for-security-reasons}"
    },
    "magento": {
        "type": "composer",
        "url": "https://repo.magento.com"
    },
    "amasty": {
        "type": "composer",
        "url": "https://composer.amasty.com/community/"
    }
}

}

It seems the installer tries to install old packages. We are using PHP 7.1. Can anybody help out?

  • might be a reference for you magento.stackexchange.com/questions/242810/… – fmsthird Jan 8 at 8:44
  • Many thx, that might be the issue. Do you know how to stop all cronjobs? Cron is not running on my staging enviroment, but it is still not working. – Coen Ponsen Jan 8 at 9:18
  • I deleted all cronjobs from db, however it is not working for me... – Coen Ponsen Jan 8 at 9:29
  • ah I see. can you post your composer.json file – fmsthird Jan 8 at 11:12
  • I added my composer.json, thx – Coen Ponsen Jan 8 at 22:03
0

I'm having the same issue. What i have done to upgrade Magento 2.3.0 is excluded weltpixel in composer.json (and remove composer.lock). So i was able to upgrade Magento but now trying to add weltpixel with the following command:

composer require "weltpixel/module-google-tag-manager-theme"

Getting the following errors:

composer require "weltpixel/module-google-tag-manager-theme"
Using version ^1.7 for weltpixel/module-google-tag-manager-theme
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/module-backend 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.1 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.0-rc3 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.0-rc2 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.1.0-rc1 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - magento/module-backend 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.26) does not satisfy that requirement.
    - Conclusion: don't install magento/module-backend 100.1.11
    - Installation request for weltpixel/module-google-tag-manager-theme ^1.7 -> satisfiable by weltpixel/module-google-tag-manager-theme[1.7.5].
    - magento/module-backend 100.2.0-rc20 requires magento/framework 100.2.* -> satisfiable by magento/framework[100.2.0-rc20].
    - magento/framework 100.2.0-rc20 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.0-rc21 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.0-rc22 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.0-rc23 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.0-rc30 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.0 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.1 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.2 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.3 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - magento/framework 101.0.4 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
    - Conclusion: don't install composer/composer 1.4.1|install magento/module-backend 100.1.11
    - weltpixel/module-google-tag-manager-theme 1.7.5 requires magento/module-backend 100.* -> satisfiable by magento/module-backend[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.8, 100.1.1, 100.1.2, 100.0.9, 100.1.3, 100.0.10, 100.2.0-rc20, 100.2.0-rc21, 100.2.0-rc22, 100.2.0-rc23, 100.2.0-rc30, 100.1.4, 100.0.11, 100.2.0, 100.2.1, 100.1.5, 100.1.6, 100.2.2, 100.0.12, 100.1.7, 100.2.3, 100.1.8, 100.2.4, 100.2.5, 100.1.9, 100.1.10, 100.2.6, 100.1.11, 100.2.7].
    - magento/module-backend 100.2.7 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.6 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.5 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.4 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.3 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.2 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.1 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.0 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.0-rc30 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.0-rc23 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.0-rc22 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/module-backend 100.2.0-rc21 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7].
    - magento/framework 101.0.5 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.6 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - magento/framework 101.0.7 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
    - Conclusion: don't install colinmollenhour/php-redis-session-abstract v1.3.4|install magento/framework 101.0.0-rc21|install magento/framework 101.0.0-rc22|install magento/framework 101.0.0-rc23|install magento/framework 101.0.0-rc30|install magento/framework 101.0.0|install magento/framework 101.0.1|install magento/framework 101.0.2|install magento/framework 101.0.3|install magento/framework 101.0.4|install magento/module-backend 100.2.0-rc20|install magento/module-backend 100.1.11


Installation failed, reverting ./composer.json to its original content.

If any one knows pls help!

  • Received a reply from weltpixel support: Our extensions are compatible with M2.3.0 starting with release 1.8.0 (December 8, 2018). Older releases are not compatible with M2.3.0. You can find the latest version of our extension on weltpixel.com. At the moment the latest update is not available in Magento Marketplace. – G. Titulaer Jan 24 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.