4

I'm using Magento 1.7, and it uses the UPS shipping calculator at

http://www.ups.com/using/services/rave/qcostcgi.cgi

Since yesterday afternoon, it has been returning a 404 not found and this is preventing anyone from placing an order! I'm very surprised that the entire Magento community isn't on fire with this event... so maybe I just have an old URL that nobody is using anymore? Does anyone know if this service has been retired or if it is a temporary outage?

9

You simply need to update the UPS Gateway URL to use "https"

To change this setting, login to the backend of your Magento website and then go to :

  1. System > Configuration
  2. Click “Shipping Methods”
  3. Click the tab for “UPS”
  4. Find the “Gateway URL” setting and change the url from “http://www.ups.com/using/services/rave/qcostcgi.cgi” to “https://www.ups.com/using/services/rave/qcostcgi.cgi”.

I put together a quick video on how to fix it here: https://www.youtube.com/watch?v=VNHQb3X7Lys&feature=youtu.be

1

Ok, I figured it out, the shipping gateway now requires https instead of http.

https://www.ups.com/using/services/rave/qcostcgi.cgi

Though, it is disturbing that I can't find any documentation about this API on UPS's website.

protected by Community May 31 at 4:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.