1

It seems like since today morning UPS rates are not loading. When I enable the UPS debug I get the following in result

    2019-01-07T11:24:09+00:00 DEBUG (7): Array
(
    [request] => Array
        (
            [accept_UPS_license_agreement] => yes
            [10_action] => 4
            [13_product] => SKU1
            [14_origCountry] => US
            [15_origPostal] => 07647
            [origCity] => 
            [19_destPostal] => 60605
            [22_destCountry] => US
            [23_weight] => 12.9
            [47_rate_chart] => Customer Counter
            [48_container] => 00
            [49_residential] => 01
            [weight_std] => lbs
        )

    [result] => \<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">
\<HTML>
\<HEAD>
\<TITLE>Error 404--Not Found\</TITLE>
\</HEAD>
\<BODY bgcolor="white">
\<FONT FACE=Helvetica>\<BR CLEAR=all>
\<TABLE border=0 cellspacing=5>\<TR>\<TD>\<BR CLEAR=all>
\<FONT FACE="Helvetica" COLOR="black" SIZE="3">\<H2>Error 404--Not Found\</H2>
\</FONT>\</TD>\</TR>
\</TABLE>
\<TABLE border=0 width=100% cellpadding=10>\<TR>\<TD VALIGN=top WIDTH=100% BGCOLOR=white>\<FONT FACE="Courier New">\<FONT FACE="Helvetica" SIZE="3">\<H3>From RFC 2068 \<i>Hypertext Transfer Protocol -- HTTP/1.1\</i>:\</H3>
\</FONT>\<FONT FACE="Helvetica" SIZE="3">\<H4>10.4.5 404 Not Found\</H4>
\</FONT>\<P>\<FONT FACE="Courier New">The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.\</p>\<p>If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.\</FONT>\</P>
\</FONT>\</TD>\</TR>
\</TABLE>

\</BODY>
\</HTML>

    [__pid] => 7111
)

I tried with multiple Magento1 project and I got the same result. Is this known issue or did someone receive this kind of issue ?

10

I found the issue. You must change the "gateway URL" in your shipping methods > UPS to: HTTPS:

https://www.ups.com/using/services/rave/qcostcgi.cgi

Soon as i did. It now works.

  • Yes , it also did work for me – Pravin Jan 7 at 16:28
0

I am also seeing this and have reached out to our UPS reps for clarification.

I have two installs (1.9.3 and 1.14.3) both not retuning UPS rates when using the native Magento United Parcel Service setting in the UPS shipping methods.

However, if you have a UPS developer account and have set up your access license number for API's you can switch to the United Parcel Service XML setting in Magento. Then enter license number and developer username and password. Then dump the caches and you will then return UPS shipping quotes for orders. This setting will also allow you to use your negotiated rates from UPS if you have any with your account.

I will update once I have official answers from UPS team for using default UPS settings.

-1

Found the solution:

Go to your backend, click System, Configuration, Shipping Methods. Under the "Gateway URL" change the URL to "https" from "http"

protected by Community Jan 7 at 16:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.