0

So this is bit of a weird one. There were a couple of orders created in the shop I run, but there was no shipping address in them. When I tried to reorder from the backend, the shipping address section was greyed out, and

"You don't have to select a shipping address."

was being shown.

Even in the shipping method section,

"You don't have to select a shipping method."

This has never happened before, and googling it returned nothing except some translation CSVs.

Help!

  • Is your ordered product are virtual ? check it. – Himanshu Jan 7 at 8:50
0

It smells like the products in that orders are virtual

This is a common issue for all those who didn't use weight attribute in Magento1 (I believe most of us). If that attribute is empty in Magento2 then application automatically changes their product type to virtual type. Orders with virtual products has no shipping management

There are lot of references about this, for instance Converting virtual products in Magento 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.