0

I'm trying to upgrade 2.2.6

When I run the web setup wizard I get this response.

Check Component Dependency

We found conflicting component dependencies.

Command "update" failed: Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

- magento/product-community-edition 2.2.7 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
- magento/product-community-edition 2.2.7 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1].
- Conclusion: don't install composer/composer 1.4.1
- Installation request for magento/product-community-edition 2.2.7 -> satisfiable by magento/product-community-edition[2.2.7].

When I try the command line upgrade I just get memory errors due to forkbomb protection.

My composer version is 1.6.4 so newer than 1.4.1

The site is on shared hosting so I can't downgrade or upgrade composer.

  • Will deleting the vendor folder and running composer install and composer update fix this? – Denial Design Jan 5 at 14:13
0

I used a different composer.json file from a fresh install of 2.2.6 and added in the required extensions and the upgrade worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.