0

I have installed Magento 2.3.0 from site ground, when clicking the link to my website i get this:

Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE) in /home/motiveat/public_html/vendor/magento/framework/Filesystem/Directory/Write.php on line 35

what do i do?, what have i done wrong? i am not tech savvy and just want to build my website

thanks

1
  • Please check the php version? If lower then update it! Jan 3, 2019 at 13:55

2 Answers 2

0

Php requirment form magento 2.3.0 is 7.1.3+ or 7.2.x . please check your php version and upgrade php version.

for more details refer https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

1
  • I have scrolled down to PHP version manager and changed it to PHP 7.2.13 but it is still stating error message? am i doing it wrong
    – Grace o
    Jan 3, 2019 at 22:02
0

In my case the error still occurred after the accepted fix. Solution was to update PHP version from 7.0 to 7.2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.