2

I am creating a new template theme for my magento store, I am using an old version of magento so I thought I would upgrade to the new version.

I am creating it on a new store in a subdirectory but it seems sooo slow compared to the current version of magento. I am still using all the same themes & extensions.

I have run a webpage speed test and it is saying when on a product page (http://www.hjtemplate.hjjewellery.co.uk/category-1/product-1.html) it is also trying to load this URL (http://www.hjtemplate.hjjewellery.co.uk/category-1/)

The only problem is.. that isn't my category URL, my category URLs end with .html so it is returning a 404 error. Any ideas why this is happening and what can I do to fix this?

Thanks

  • Can you see what is trying to load this page? It sounds a bit odd. – David Manners Jul 25 '14 at 13:36
2

The url your product page is loading is loaded by your CloudZoom module (javascript). On line 173 of cloud-zoom.1.0.2.js you have this line :

$mouseTrap = jWin.parent().append(format("<div class='mousetrap' style='background-image:url(\".\");z-index:999;position:absolute;width:%0px;height:%1px;left:%2px;top:%3px;\'></div>", sImg.outerWidth(), sImg.outerHeight(), 0, 0)).find(':last');

The part background-image:url(\".\") is loading an image from the parent path so http://www.hjtemplate.hjjewellery.co.uk/category-1/

Try it using your browser to see by yourself (Chrome helps a lot tracing javascript errors in the console).

Maybe your module misses some config for that background-image. Find out what it is doing on that line, and what is supposed to replace the path in the background-image directive.

  • Nice one! just removed the background-image. thanks – Claudiu Creanga Mar 6 '15 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.