0

I am new in Magento 2 and today i installed it in my system window 7, and i am using xampp server. my problem is that when i go through this link http://localhost/magento/ then during this an error generating such as:

Autoload error

Vendor autoload is not found. Please run 'composer install' under application root directory.

and then after i run this command link composer install in command prompt then lots of error i am getting in command prompt like this showing you an image see that please and guide me: enter image description here

can anybody help me please i am new here, step by step guide me.

1

Magento 2 depends on a number of PHP extensions that you don't have installed.

Since you're using XAMP you'll need to edit your C:\xampp\php\php.ini file and enable each extension as it says in the error message.

To enable the missing extensions:

  1. Make a backup copy of your C:\xampp\php\php.ini file in case something breaks

  2. Open up the original C:\xampp\php\php.ini in notepad or any text editor

  3. Remove the ; from the start of the line, of each extension you want to enable ex. ;extension=php_intl.dll ;extension=php_soap.dll ;extension=php_xsl.dll

  4. Make sure to save your changes to the file

  5. Restart XAMP

  6. Try to run composer install again

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.