0

I put my code on server and when I deployed it i get the error Internal server 500 so I deleted the .htaccess from the root of directory but css and js not loading and run deploy the update the di:compile and put 777 /var /generated pub/media and pub/static when i see the folder under pub/static /frontend .fr_FR/theme/it is empty same for media no wysiwyg and there are some folder related to theme missing on server. In local everything is working fine.

  • Please check the file permission where you put your new code. if you are in production mode then please run static content deploy, then give permission 777 to pub ,var, generated – Pritam Info 24 Dec 28 '18 at 13:53
  • i really did that but still same error – Developper Magento Dec 28 '18 at 14:00
  • one queston when i delete the .htaccess i find the Fo without css and js else if i keep it i get the intenal server error 500 – Developper Magento Dec 28 '18 at 14:01
  • There probably two reasons for that. 1. some PHP module is lot loading or some misconfiguration 2. File permission. You may try solutions form this link magento.stackexchange.com/questions/100896/…, Thank you. – Pritam Info 24 Dec 28 '18 at 14:08
1

Run below command step by step and check.

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy -f

Php bin/magento cache:flush

Hope it help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.