2

I'm deploying on ubuntu ec2 instance and it had worked fine at first.

but now when I deployed some updates and tried to open the store it gives me the page in the image enter image description here

why that's happening

1
  • Is this the whole image or anything else as I am seeing there are some folders and files are missing in the screenshot? Dec 27, 2018 at 14:50

3 Answers 3

1

you are missing the .htaccess file?

this file is a hidden file that is shipped with magento and easy to miss when moving things / migrating..

1

It looks like a rewrite rule problem. Make sure that .htaccess file is not missing as Herve said above. Also make sure that rewrite rule is enabled, if not you can do that by using the command line sudo a2enmod rewrite enabling the rewrite mode on ubuntu. After that you can also check if the site rewrite is enabled and etc.

1
  • when I allowed rewrite I got index.php code in the browser Dec 27, 2018 at 15:41
0

There can be multiple problems because of which it is showing as filesystem -

It may be so that php is not running, otherwise the index.php should have been executed.

It may also be that you may have opened file system through browser and it is not opened through localhost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.