1

I donot understand why my routes.xml is not working , see this and tell me if you get something wrong in it . thats the code snippet .

<?xml version="1.0" ?>
    <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:App/etc/routes.xsd">
        <router id="admin">
            <route frontName="checkcustomattribute" id="checkcustomattribute">
                <module name="CheckCustom_Attributed"/>
            </route>
        </router>
    </config>

module is perfectly installed i have checked it , folder structure for admin route is etc/adminhtml/routes.xml , for front router etc/frontend/routes.xml . and i am on developer mode i am seeing no error everything in code structure seems ok so what is going wrong in it . I have even tried different route id and front name .

  • shair all file like phtml contoller – Adarsh Shukla Dec 24 '18 at 4:44
  • and layout file with thair names because name of layout file is wrong i think – Adarsh Shukla Dec 24 '18 at 4:44
2

Please make sure you enabled your custom module by run the following command:

  1. Setup upgrade:

php bin/magento s:up

  1. Check module is enabled:

php bin/magento module:status CheckCustom_Attributed

Make sure your admin controller extends the Magento\Backend\App\Action class and the controller class must be under CheckCustom/Attributed/Controller/Adminhtml folder

With the frontend controller, if you created a controller class, example:

CheckCustom/Attributed/Controller/Check/Attribute.php

so the url that you should to enter is {base_url}/checkcustomattribute/check/attribute

Hope this will solve your issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.