0

How do I resolve this issue? The Marketing -> Cart Price Rules keeps spinning and not loading. Following is the error message from chrome enter image description here

/pub/static/version1544579836/adminhtml/Magento/backend/en_US/Magento_SalesRule/js/form/element/coupon-type.js:1 Failed to load resource: the server responded with a status of 500 ()
    /pub/static/version1544579836/adminhtml/Magento/backend/en_US/Magento_SalesRule/js/form/element/manage-coupon-codes.js:1 Failed to load resource: the server responded with a status of 500 ()
    /pub/static/version1544579836/adminhtml/Magento/backend/en_US/Magento_Ui/js/form/element/single-checkbox-toggle-notice.js:1 Failed to load resource: the server responded with a status of 500 ()
    console-output-handler.js:34 [2018-12-20 09:32:29] [ERROR] Failed to load the "Magento_SalesRule/js/form/element/coupon-type" component.
    ConsoleOutputHandler.show @ console-output-handler.js:34
    console-output-handler.js:34 [2018-12-20 09:32:29] [ERROR] Failed to load the "Magento_SalesRule/js/form/element/manage-coupon-codes" component.
    ConsoleOutputHandler.show @ console-output-handler.js:34
    console-output-handler.js:34 [2018-12-20 09:32:29] [ERROR] Failed to load the "Magento_Ui/js/form/element/single-checkbox-toggle-notice" component.
    ConsoleOutputHandler.show @ console-output-handler.js:34
    /pub/static/version1544579836/adminhtml/Magento/backend/en_US/Magento_Ui/templates/form/element/helper/tooltip.html:1 Failed to load resource: the server responded with a status of 500 ()
    console-output-handler.js:34 [2018-12-20 09:32:29] [ERROR] Failed to load the "ui/form/element/helper/tooltip" template requested by "sales_rule_form.sales_rule_form.rule_information.website_ids".
1

You Can try to remove static content and then try static Content Deploy as describe below.

1) Set Magento 2 developer mode.

sudo php bin/magento deploy:mode:set developer

2) Remove Static Content for adminhtml.

sudo rm -rf pub/static/adminhtml/*

3) try forced Content Deploy

sudo php bin/magento setup:static-content:deploy -f

4) Give permission to pub, var, generated

sudo chmod -Rv 777 pub var generated
  • thank you, i will give it a try and report back! – Kris Wen Dec 26 '18 at 17:12
  • @Ashish Viradiya Welcome. – Pritam Info 24 Dec 28 '18 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.