1

I have php7.2 and composer installed via apt-get

When I try to install Magento 2.3 via composer... composer create-project --repository=https://repo.magento.com/ magento/projec t-community-edition

I have this issue:

our requirements could not be resolved to an installable set of packages. Problem 1

    - magento/inventory-composer-installer 1.0.3 requires composer-plugin-api ^1.1 -> no matching package found.
    - magento/product-community-edition 2.3.0 requires magento/inventory-composer-metapackage ^1.0.3 -> satisfiable
 by magento/inventory-composer-metapackage[1.0.3].
    - magento/inventory-composer-metapackage 1.0.3 requires magento/inventory-composer-installer ^1.0.3 -> satisfia
ble by magento/inventory-composer-installer[1.0.3].
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-
edition[2.3.0].

Potential causes:

3
  • magento.stackexchange.com/questions/251838/… Commented Dec 20, 2018 at 11:53
  • 3
    Ok, issue was on composer version, I updated it and now it's all Okay, Thanks @RaulSanchez Commented Dec 20, 2018 at 13:39
  • Same with me it's just the composer version. I updated it to the latest one and now the magento 2 upgrade is moving. Thanks Commented Mar 8, 2019 at 5:51

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.