1

Basically i want to update my store from 2.1.9 to 2.2.0. But when i run composer update i'm getting this error:

- magento/product-community-edition 2.2.0 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7, 2.7.x-dev] but these conflict with your requirements or minimum-stability.
    - magento/product-community-edition 2.2.0 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7, 2.7.x-dev] but these conflict with your requirements or minimum-stability.
    - Installation request for magento/product-community-edition 2.2.0 -> satisfiable by magento/product-community-edition[2.2.0].

And then i run this command:

composer require zendframework/zend-stdlib ^2.7.7 --no-update

And then composer update again and i get this error:

Problem 1
    - magento/framework 100.1.16 requires zendframework/zend-stdlib ~2.5.0 -> satisfiable by zendframework/zend-stdlib[2.5.0, 2.5.1, 2.5.2] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.15 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.14 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.13 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.12 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.11 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.10 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.9 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.8 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.7 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.6 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.5 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.4 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.3 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.16 requires zendframework/zend-stdlib ~2.5.0 -> satisfiable by zendframework/zend-stdlib[2.5.0, 2.5.1, 2.5.2] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.15 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.14 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.13 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.12 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.11 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.10 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.9 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.8 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.7 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.6 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.5 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.4 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.3 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - magento/framework 100.1.9 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9] but these conflict with your requirements or minimum-stability.
    - Conclusion: don't install magento/product-community-edition 2.2.0
    - Installation request for magento/product-community-edition 2.2.0 -> satisfiable by magento/product-community-edition[2.2.0].
    - magento/data-migration-tool 2.1.2 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.10, 100.1.11, 100.1.12, 100.1.13, 100.1.14, 100.1.15, 100.1.16].
    - magento/data-migration-tool 2.1.2 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.10, 100.1.11, 100.1.12, 100.1.13, 100.1.14, 100.1.15, 100.1.16].
    - magento/data-migration-tool 2.1.2 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.9, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.10, 100.1.11, 100.1.12, 100.1.13, 100.1.14, 100.1.15, 100.1.16].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc1].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc2].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc3].
    - Can only install one of: magento/framework[101.0.0, 100.1.0].
    - Can only install one of: magento/framework[101.0.0, 100.1.1].
    - Can only install one of: magento/framework[101.0.0, 100.1.2].
    - Can only install one of: magento/framework[101.0.0, 100.2.0-rc20].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc1].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc2].
    - Can only install one of: magento/framework[101.0.0, 100.1.0-rc3].
    - Can only install one of: magento/framework[101.0.0, 100.1.0].
    - Can only install one of: magento/framework[101.0.0, 100.1.1].
    - Can only install one of: magento/framework[101.0.0, 100.1.2].
    - Can only install one of: magento/framework[101.0.0, 100.2.0-rc20].
    - magento/product-community-edition 2.2.0 requires magento/framework 101.0.0 -> satisfiable by magento/framework[101.0.0].
    - Conclusion: don't install magento/framework 101.0.0
    - Installation request for magento/data-migration-tool 2.1.2 -> satisfiable by magento/data-migration-tool[2.1.2].

What should i do? :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.