1

I have been trying to update my site to 2.3 and I am getting the error posted below when I use CLI with command composer update. I have also tried to use the online system upgrade tool and get the error "We found conflicting component dependencies".

I am newer to Magento and still somewhat confused about where to update dependencies, I have some in my root directory composer.json but most of them are in the magento\framework directories composer.json. Please let me know if you can help me get this resolved.

Loading composer repositories with package information Updating dependencies (including require-dev)Your requirements could not be resolved to an installable set of packages.
     Problem 1
        - Conclusion: don't install magento/product-community-edition 2.3.0
        - magento/data-migration-tool 2.2.7 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
        - magento/data-migration-tool 2.2.7 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
        - magento/data-migration-tool 2.2.7 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
        - magento/data-migration-tool 2.2.7 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.7, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6].
        - magento/framework 101.0.1 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
        - magento/framework 101.0.2 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
        - magento/framework 101.0.3 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
        - magento/framework 101.0.1 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
        - magento/framework 101.0.2 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
        - magento/framework 101.0.3 requires colinmollenhour/php-redis-session-abstract 1.3.4 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.3.4].
        - magento/framework 101.0.0 requires colinmollenhour/php-redis-session-abstract ~1.2.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2.2].
        - magento/framework 101.0.0 requires colinmollenhour/php-redis-session-abstract ~1.2.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2.2].
        - magento/framework 101.0.7 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.4 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.5 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.6 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.7 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.4 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.5 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.6 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - magento/framework 101.0.7 requires magento/zendframework1 ~1.13.0 -> satisfiable by magento/zendframework1[1.13.1, 1.13.0].
        - Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.0, v1.3.4].
        - Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.0, v1.3.4].
        - Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.0, v1.2.2].
        - Can only install one of: magento/zendframework1[1.14.1, 1.13.0].
        - Can only install one of: magento/zendframework1[1.14.1, 1.13.1].
        - Can only install one of: magento/zendframework1[1.14.1, 1.13.1].
        - magento/product-community-edition 2.3.0 requires colinmollenhour/php-redis-session-abstract ~1.4.0 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.4.0].
        - magento/product-community-edition 2.3.0 requires magento/zendframework1 ~1.14.1 -> satisfiable by magento/zendframework1[1.14.1].
        - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
        - Installation request for magento/data-migration-tool 2.2.7 -> satisfiable by magento/data-migration-tool[2.2.7].
0

If You have some custom modules, save them somewhere and delete from magento, then upgrade to new version of magento and copy modules into project like it was before. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.