Error in Installation:

[php7:error] [pid 10084:tid 1952] [client ::1:53679] PHP Fatal error: Uncaught RuntimeException: The path "C:/xampp/htdocs/magento/lavoska/generated/code/Magento/Swatches/Block/Adminhtml/Product/Attribute/Edit/FormFactory.php.10084" cannot be renamed into "C:/xampp/htdocs/magento/lavoska/generated/code/Magento/Swatches/Block/Adminhtml/Product/Attribute/Edit/FormFactory.php" Warning!rename(C:/xampp/htdocs/magento/lavoska/generated/code/Magento/Swatches/Block/Adminhtml/Product/Attribute/Edit/FormFactory.php.10084,C:/xampp/htdocs/magento/lavoska/generated/code/Magento/Swatches/Block/Adminhtml/Product/Attribute/Edit/FormFactory.php): The process cannot access the file because it is being used by another process. (code: 32)\r\nClass Magento\Swatches\Block\Adminhtml\Product\Attribute\Edit\FormFactory generation error: The requested class did not generate properly, because the 'generated' directory permission is read-only. If --- after running the 'bin/magento setup:di:compile' CLI command when the 'generated' directory permission is set to write --- the requested class did not generate in C:\xampp\htdocs\magento\lavoska\vendor\magento\framework\Code\Generator.php on line 135, referer: http://localhost:81/magento/lavoska/setup/


if you are on windows open the folder and give permissions to generated folder to "uncheck" read only and for linux operating systems use chmod -R 755 generated and you will be able to install the magento 2.3.1


You must set the permission for project and you can do it with you must click right to folder project and unchecked the "Read-only" for all files and folders from project.

  • I have done that, but that is not unchecking. When process done, that seems again checked. Can you suggest me that why is it happening? – Learner Dec 21 '18 at 15:38
  • After unchecked please run all commands which you need and after that re-unchecked. – St3phan Dec 21 '18 at 20:02
  • How install ? in browser or with CLI command ? – St3phan Dec 21 '18 at 20:03
  • in browser..... – Learner Dec 24 '18 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.