0

I am running Magento 2.2.6 and it's a slow instance so I wanted to try out the Mirasvit profiler. However, when I try to enable it, I get an error about yaml not being installed. I dug through the issues on github (https://github.com/mirasvit/module-profiler/issues) and on this issue (https://github.com/mirasvit/module-profiler/issues/36), I found a suggestion of using the dev-master branch of the profiler.

I tried that, and got this:
Problem 1
- Installation request for mirasvit/module-profiler dev-master -> satisfiable by mirasvit/module-profiler[dev-master].
- mirasvit/module-profiler dev-master requires symfony/yaml dev-issue-8145 -> satisfiable by symfony/yaml[dev-issue-8145] but these conflict with your requirements or minimum-stability.

If I try to run composer require symfony/yaml, I get symfony/yaml v3.4.0 conflicts with symfony/console[v2.8.*]. I tried installing yaml:2.8.49 and got this result:
Problem 1
- symfony/yaml v2.8.49 conflicts with symfony/dependency-injection[v3.4.20].
- symfony/yaml v2.8.49 conflicts with symfony/dependency-injection[v3.4.20].
- symfony/yaml v2.8.49 conflicts with symfony/dependency-injection[v3.4.20].
- Installation request for symfony/yaml 2.8.49 -> satisfiable by symfony/yaml[v2.8.49].
- Installation request for symfony/dependency-injection (locked at v3.4.20) -> satisfiable by symfony/dependency-injection[v3.4.20].

I've cleared the composer cache, run composer update to update existing components and cleared Magento caches and generated files, to no avail.

How do I get this profiler working? Failing that, is there another Magento 2 profiler that I can use that's comparable to Mirasvit?

  • In composer.json, the composer/composer version is set strictly. Update it with ^ and try again the composer update. – Milind Singh Dec 18 '18 at 18:43
  • Update which component? – Marisa Dec 18 '18 at 18:44
  • run composer update – Milind Singh Dec 18 '18 at 18:45
  • I used composer update, unless you mean I need to target a specific module. – Marisa Dec 18 '18 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.