1

After updated magento from 2.1 to 2.3 I've got a require js error in console:

Uncaught Error: Script error for: ModuleName

I made an investigation and find out that require.js core file in the function req.load is trying to create node document.createElement('script') and then checks if this node has attachEvent property. In my case it's script node. And there is no attachEvent property. By this reason I've got an error. Can somebody explain why it happens? Everything was good before and code seems was the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.