1

Recently I had upgraded version from 2.2.6 to 2.3.0 everything is working fine except frontend.It is showing below exception.Admin working perfectly.

1 exception(s):Exception #0 (Magento\Framework\Exception\RuntimeException): Type Error occurred when creating object: Magento\Cms\Model\Wysiwyg\CompositeConfigProvider

Exception #0 (Magento\Framework\Exception\RuntimeException): Type Error occurred when creating object: Magento\Cms\Model\Wysiwyg\CompositeConfigProvider 0/var/www/magentohost/public_html/vendor/magento/framework/ObjectManager/Factory/Compiled.php(108): Magento\Framework\ObjectManager\Factory\AbstractFactory->createObject('Magento\Cms\Mod...', Array)

0

Finally I solved the Issue By Removing Plumrocket Extension.This extension caused the bug in Magento 2.3.0..!!

0

Try the following,

This error usually means your generated sources are out of date. It doesn't seem to recognize that the $pricingHelper argument is there, which suggests it hasn't always been (extension upgrade?). Give this a try from SSH:

Change directories to your web root (the base Magento folder) Run these commands:

php bin/magento cache:clean rm -r var/di var/generation php bin/magento setup:di:compile

The first one flushes Magento's cache, to make sure nothing is stuck/out of date there. The second one clears out all existing generated source files. And finally, the third generates fresh copies. When that's done, give it another try.

  • Finally I solved the Issue By Removing Plumrocket Extension.This extension caused the bug in Magento 2.3.0..!! – Jithu Dec 18 '18 at 6:48
1

You have the issue at __construct(.

You must pass context object \Magento\Framework\App\Action\Context $context to parent class Magento\Framework\App\Action\Action

public function __construct(
\Magento\Framework\App\Action\Context $context,
    CustomHelper $helper
) {
    $this->helper = $helper;
parent::__construct($context);
}

after this changes donot forgot to do Di compile

  • On which file to add this line? – Jithu Dec 17 '18 at 13:13
  • The file you mentioned, Magento\Cms\Model\Wysiwyg\CompositeConfigProvider – Prema Karthik Dec 17 '18 at 13:14
  • I added above line inside the construct but no change same error showing again... – Jithu Dec 17 '18 at 13:21
  • Hey Somebody please help me to fix this issue otherwise my client will fire me from this project..It's urgent – Jithu Dec 18 '18 at 5:07
  • Finally I solved the Issue By Removing Plumrocket Extension.This extension caused the bug in Magento 2.3.0..!! – Jithu Dec 18 '18 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.