0

I'm having an issue with magento not sending any emails. I've already tested some solutions and it's not worked.

I'm using a SMTP extension and Magento 2.2.6: https://github.com/mageplaza/magento-2-smtp And always getting an error when testing the extensions configs: enter image description here

I also checked var/log and no errors were found.

0
  1. Hosting Provider Block Sending ports Your hosting/server may block 25, 465, or 587 port.

  2. Firewall Your server firewall may block the SMTP host or ports, try to check these things.

  • 1. I already contacted my host provider to check if there is anything blocking outgoing mail, I'm just waiting for an answer... 2. Is there a way so I can check this through SSH? – Leto Dec 14 '18 at 18:43
0

As there is no error in the logs, it seems that Disable Email Communications option in Mail Sending Settings is set to Yes, . Please, follow these steps:

  1. Head to Stores > Configuration > Advanced > System.
  2. Find Disable Email Communications option under Mail Sending Settings. Set it to No.

It should fix your issue.

  • Hi! Thank you for your reply but It's not the case. Mail Sending Settings is already marked as 'No' – Leto Dec 14 '18 at 18:42
0

I finally found a solution. My host provider (Digital Ocean) was blocking outgoing mails. I conctacted them and I was able to test successfully and send emails.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.