6

I've seen a lot of people with similar issues, but none of the many resolutions I've seen online have worked for my situation.

Magento 1.8 Community Edition. Admin changes are not being saved. Products are not saved, Configuration changes are not saved.

My htaccess is redirecting to get rid of the index.php

RewriteRule .* index.php [L]
RewriteCond %{REQUEST_URI} !^/index.php/admin/
RewriteRule ^index.php/(.*) $1 [R=301,QSA,L]

I use the same htaccess file on an older separate site with no issues.

I've noticed that in firebug, GET url requests are redirected 302, while the POST during the saving process is a 301, and calls the index.php/admin

Is this not an htaccess issue? Is there an issue in the core code redirecting the POST calls overriding htaccess?

4

I had this issue and in case anyone doesn't know the answer here it is, - the above code will also not allow checkouts or anything that requires index.php as the rule is not rewriting the index just removing it.

Follow the already posted instructions by Amit Bera to ensure you are allowing rewrites in the config then change your htaccess file to reflex this (changing base if needed)

RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

This will rewrite all index.php indexes out for you.

3

See your URL in admin if index.php is missing then you will not able to save configuration.

Most probably your .htaccess rewrite url is redirecting index.php to non index.php.

Just comment that line in your .htaccess file. and try again.

Good Rewrite Url for index.php remove from url is

#Put below code in your `.htacces` after RewriteRule `.* index.php [L])`

RewriteCond %{REQUEST_URI} !^/index.php/admin/
RewriteCond %{REQUEST_URI} !^/index.php/admin
RewriteRule ^index.php/(.*) /$1 [R=301,QSA,L]

This will only remove index.php from your frontend not from admin

2

This could be should from

Login to Admin Panel Go to System -> Configuration -> Advanced Panel -> Admin Option -> "Admin Base URL" Tab.

and Set "Allow URL rewrites" to "Enable"

  • I have a similar issue but in my case, I am unable to save Catalog page in admin section. Rest are able to save. Any idea to how to solve this! – Anurag Khandelwal Oct 13 '16 at 12:02
  • then that may any coding issue – Amit Bera Oct 13 '16 at 12:37
  • Not magento rewrite issue .. check magento 3rd pary extension – Amit Bera Oct 13 '16 at 12:38
  • Can you tell any place where to start debugging on this as there is no logs getting generated – Anurag Khandelwal Oct 13 '16 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.