After I upgraded Mageto 2.2.5 to 2.3.0 I've run all the commands in the console (upgrade,deploy,compile,flush), but on frontend it doesn't load the page and in system.log

I'm getting following error

"main.INFO: Broken reference: the 'theme.active.editor' element cannot be added as child to 'after.body.start', because the latter doesn't exist [] [] main.INFO: Broken reference: the 'logger' element cannot be added as child to 'after.body.start', because the latter doesn't exist [] []"

And in backend i have the error :ERR_TOO_MANY_REDIRECTS

Thank you for any advice

  • Drop which php version you are using and which process you followed for upgrade.
    – Aman Alam
    Dec 11, 2018 at 12:28
  • i am using php 7.1 and i've upgraded magento with composer
    – gabi
    Dec 11, 2018 at 12:40
  • Have you followed upgrade doc provided by Magento its bit different process the previous upgrade process.
    – Aman Alam
    Dec 11, 2018 at 12:43
  • i have used this script github.com/magento/magento2/blob/2.3-develop/dev/tools/… and then composer update
    – gabi
    Dec 11, 2018 at 12:46
  • Then should be good is setup:upgrade command run successfully?
    – Aman Alam
    Dec 11, 2018 at 12:50

2 Answers 2


The issue in our layout.

First, on the layout, you have a section name theme.active.editor .

ERR_TOO_MANY_REDIRECTS happen for cookie setting issue at magento.Please check the cookie setting at core_config_data table.

Run below query:

select * from core_config_data where value like '%cookie%'

I guess that on your database, your cookie domain is live domain. So, you have to delete that record. and then Flush All the cache.

  • hi Amit ,my project is on local and in my database in core_config_data table i don t have nothing about cookie
    – gabi
    Dec 11, 2018 at 14:05
  • which browser, you have tried?
    – Amit Bera
    Dec 11, 2018 at 14:22
  • @AmitBera I have the same issue. We just moved the instance from nginx server to windows server, since then both frontend and backend dont work. When I open admin I got the same error logged.
    – Anto S
    Feb 28, 2019 at 7:26

First, run the below command:

SELECT * FROM `core_config_data` WHERE `path` LIKE '%base_url%'

Next, if the value is enabled SSL then fix to HTTPS and if it is disabled, please edit to HTTP.

Finally, clear cache.

Please let me know if it works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.