1

I am trying to update my Magento CE 2.2.6 to CE 2.3 with composer but am getting the following.

Reading C:/Users/garry/AppData/Local/Composer/repo/https---repo.packagist.org/provider-php-cs-fixer$diff.json from cache

Resolving dependencies through SAT
Looking at all rules.
Something's changed, looking at all rules again (pass #1800)

The pass counter keeps counting up and I have left it overnight but it does not finish, now it's been going for over an hour.

I have followed the instructions here.

I think it has something to do with friendsofphp/php-cs-fixer:~2.10.1. I have tried installing it separately but with no luck.

My composer.json

{
    "name": "magento/magento2ce",
    "description": "Magento 2 (Open Source)",
    "type": "project",
    "version": "2.2.4",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "php": "7.0.2|7.0.4|~7.0.6|~7.1.0",
        "magento/data-migration-tool": "2.2.4",
        "magento/product-community-edition": "2.3.0",
        "msp/recaptcha": "2.0.0",
        "faonni/module-indexer-url-rewrite": "^2.0"
    },
    "require-dev": {
        "phpmd/phpmd": "@stable",
        "phpunit/phpunit": "~6.2.0",
        "friendsofphp/php-cs-fixer": "~2.10.1",
        "lusitanian/oauth": "~0.8.10",
        "pdepend/pdepend": "2.5.2",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "3.2.2"
    },
    "extra": {
        "component_paths": {
            "trentrichardson/jquery-timepicker-addon": "lib/web/jquery/jquery-ui-timepicker-addon.js",
            "components/jquery": [
                "lib/web/jquery.js",
                "lib/web/jquery/jquery.min.js",
                "lib/web/jquery/jquery-migrate.js"
            ],
            "blueimp/jquery-file-upload": "lib/web/jquery/fileUploader",
            "components/jqueryui": [
                "lib/web/jquery/jquery-ui.js"
            ],
            "twbs/bootstrap": [
                "lib/web/jquery/jquery.tabs.js"
            ],
            "tinymce/tinymce": "lib/web/tiny_mce"
        }
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/",
            "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
        },
        "psr-0": {
            "": [
                "app/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "stable",
    "repositories": {
        "magento": {
            "type": "composer",
            "url": "https://repo.magento.com"
        },
        "data-migration-tool": {
            "type": "git",
            "url": "https://github.com/magento/data-migration-tool"
        }
    },
    "config": {
        "preferred-install": "dist",
        "sort-packages": true
    },
    "prefer-stable": true
}

Does anyone know how to resolve this?

Many thanks in advance.

  • There's something wrong within Composer. Either it should be able to resolve your dependencies or it should show you the conflicts it cannot resolve.It should not hang that long. Also see the thread here github.com/composer/composer/issues/7665 – 7ochem May 7 at 7:31
  • 2
    I'm voting to close this question as off-topic because this is a Composer issue, not a Magento issue – 7ochem May 7 at 7:31
1

I found that if I used PHP 7.2.4 rather than 7.1.24 for the composer update it worked correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.