1

I am new to magento and I am facing a problem with Magento ver. 1.8.0.0. Image import is working fine but when I try to upload image it don't work. My cache is disabled and media folders is 777. I have added front end and back end screenshots for you to have a look.

Any help will be really appreciated.

Thanks AM

enter image description here

enter image description here

3
  • check your ` catalog_product_entity_media_gallery` table in your database, you might have a hint towards why it doesn't work properly. Would you have a screenshot of the error shown to you when uploading images? Jun 27 '14 at 13:20
  • Thanks Michael. I will have a look at the database. I don't get any error so I can't provide you with a screenshot I am afraid.
    – Ali
    Jun 27 '14 at 13:28
  • Enable logging to system.log. Upon upload, check for new entries. Post results here (also if no errors). Also make sure all subdirectories are writeable. You can ensure they are with find media -type d -exec chmod a=rwx {} +
    – Melvyn
    Jun 27 '14 at 21:45
1

@Ali, please check the following thinks before upload the image csv.

  1. You have to be sure that all your fields are filled in Excel or Open Office Calc
  2. Save the file as CSV.
  3. Open the file with a text editor.
  4. Go to File and after that - Save As. Your filename should end with “.csv
  5. Under Save as type select All files.
  6. Under Encoding you just have to select UTF-8 and save the file - Save the file.

And also can you see the following tips url http://www.file2cart.com/blog/6297-five-most-common-magento-image-import-problems

2
  • Hi Supravat, thank you for your reply. I can upload the images using a CSV file with no problem. I am facing a problem when I try to upload them individually while editing the product. Thanks
    – Ali
    Jun 27 '14 at 13:23
  • Hi Ali, Please check your console when you save the image of product. This problem may be occur from your js file. Jun 29 '14 at 6:17
0

You need to select the radio buttons Base Image Small Image and Thumbnail next to the image you uploaded then save the changes.

These are the 3 types of image Magento will use, if you wanted you could select a different Thumbnail Image, for example.

3
  • Michael, Thank you very much for your answer. I am sorry for not being clear.I did assign those images to Base Image, Small Image, Thumbnail image and saved changes several time but they are not showing up. I also checked the URL link of the images but the image is not available although I uploaded it and saved it. Thanks for your help.
    – Ali
    Jun 27 '14 at 12:37
  • Hi Ali, you're question was very clear and well presented. Did you understand my answer? Jun 27 '14 at 12:39
  • Please read above.
    – Ali
    Jun 27 '14 at 13:07
-2

Try removing the .htaccess file in the Media folder? They often cause issues

Henry

1
  • Doing so might cause other issues. You can try this, but the media folder .htaccess needs to be there. Feb 16 '15 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.