0

i've a problem with paypal checkout, i've configurated all correctly but on checkout return page says "wrong paypal express checkout token specified" attached payment log (all seem's ok but order it's not successful) I've searched on web but no solution found, the problem is on magento 2.2.5 and 2.3 too

[2018-12-07 10:38:17] main.DEBUG: array (
  'url' => 'https://api-3t.paypal.com/nvp',
  'SetExpressCheckout' =>
  array (
    'PAYMENTACTION' => 'Sale',
    'AMT' => '14.00',
    'CURRENCYCODE' => 'EUR',
    'RETURNURL' => 'http://magento2.gioglipesca.it/paypal/express/return/',
    'CANCELURL' => 'http://magento2.gioglipesca.it/paypal/express/cancel/',
    'INVNUM' => '000000075',
    'SOLUTIONTYPE' => 'Sole',
    'GIROPAYCANCELURL' => 'http://magento2.gioglipesca.it/paypal/express/cancel/',
    'GIROPAYSUCCESSURL' => 'http://magento2.gioglipesca.it/checkout/onepage/success/',
    'BANKTXNPENDINGURL' => 'http://magento2.gioglipesca.it/checkout/onepage/success/',
    'SHIPPINGAMT' => '5.00',
    'ITEMAMT' => '7.38',
    'TAXAMT' => '1.62',
    'BUSINESS' => 'Giogli Pesca',
    'NOTETEXT' => NULL,
    'EMAIL' => '******',
    'FIRSTNAME' => '******',
    'LASTNAME' => '******',
    'MIDDLENAME' => NULL,
    'SALUTATION' => NULL,
    'SUFFIX' => NULL,
    'COUNTRYCODE' => 'IT',
    'STATE' => '******',
    'CITY' => '******',
    'STREET' => '******',
    'ZIP' => '******',
    'PHONENUM' => '******',
    'SHIPTOCOUNTRYCODE' => 'IT',
    'SHIPTOSTATE' => '******',
    'SHIPTOCITY' => '******',
    'SHIPTOSTREET' => '******',
    'SHIPTOZIP' => '******',
    'SHIPTOPHONENUM' => '******',
    'SHIPTOSTREET2' => '',
    'STREET2' => '',
    'SHIPTONAME' => '******',
    'ADDROVERRIDE' => 1,
    'METHOD' => 'SetExpressCheckout',
    'VERSION' => '72.0',
    'USER' => '****',
    'PWD' => '****',
    'SIGNATURE' => '****',
    'BUTTONSOURCE' => 'Magento_Cart_Community',
  ),
  'response' =>
  array (
    'TOKEN' => 'EC-3NE85213955529058',
    'TIMESTAMP' => '2018-12-07T10:38:17Z',
    'CORRELATIONID' => '586972c7a2030',
    'ACK' => 'Success',
    'VERSION' => '72.0',
    'BUILD' => '000000',
  ),
) [] []
  • Did you find the answer to this? I am having the exact same problem. Regards, JC – jopecu Jun 6 at 13:08
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Manashvi Birla Jun 6 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.