0

I cannot upgrade using the admin System upgrade wizard. When I run the readiness checks everything passes apart from "Check Component Dependency". The problem reads:

" We found conflicting component dependencies. Hide detail Command "update" failed: Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0]. - magento/product-community-edition 2.3.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.32) does not satisfy that requirement. "

So I changed that in the server PHP manager the version to 7.1 and 7.2 and tried both. 7.2 just won't allow the site to work, 7.1 allows the site to work but still won't upgrade.

Can anyone please help, the server PHP from what I can tell is PHP Version 7.2.12.

Thank you.

  • You PHP version should be above 7.1.3. Try PHP version 7.1.24 tested and works fine. – Priyank Dec 5 '18 at 12:25
  • This is what happens when i use 7.1.24 ?? heck Component Dependency We found conflicting component dependencies. Hide detail Command "update" failed: Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. – Andy Semmens Dec 5 '18 at 12:36
  • several lines looking like this: – Andy Semmens Dec 5 '18 at 12:37
  • - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.24) does not satisfy that requirement. – Andy Semmens Dec 5 '18 at 12:37
  • Can only install one of: magento/framework[102.0.0, 101.0.0]. - Can only install one of: magento/framework[102.0.0, 101.0.1]. - Can only install one of: magento/framework[102.0.0, 101.0.2]. - Can only install one of: magento/framework[102.0.0, 101.0.3]. - Can only install one of: magento/framework[102.0.0, 101.0.4]. - magento/product-community-edition 2.3.0 requires magento/framework 102.0.0 -> satisfiable by magento/framework[102.0.0]. – Andy Semmens Dec 5 '18 at 12:38
0

Update Magento version using command line because web setup wizard is not recommended as it may create such problem. Below is commands to update Magento version using command line.

composer require magento/product-community-edition 2.3.0 --no-update
composer update
  • Just tried that and got the following: – Andy Semmens Dec 5 '18 at 12:06
  • [~/public_html]# composer require magento/product-community-edition 2.3.0 --no-update Your requirements could not be resolved to an installable set of packages. Problem 1 - The requested package magento/product-community-edition 2.3.0 exists as magento/product-community-edition[2.2.7, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.1.0, 2.0.8, 2.0.9, 2.1.1, 2.0.10, 2.1.2, 2.1.3, 2.0.11, 2.1.4, 2.0.12, 2.1.5, 2.0.13, 2.1.6, 2.1.7, 2.0.14, 2.0.15, 2.1.8, 2.1.9, 2.0.16, 2.2.0, 2.0.17, 2.2.1, 2.1.10] but these are rejected by your constraint. – Andy Semmens Dec 5 '18 at 12:08
  • Anyone Please help with this as solutions not working – Andy Semmens Dec 7 '18 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.