1

I am upgrading to Magento 2.2.5 to Magento 2.3.0, Some of the third party module is giving error while composer update. my current php version is 7.2.12

Can you please help me out? Please refer below screenshot:

I have also tried composer require [ModuleName] 2.3.0 --no-update But it is giving package not found error:

[InvalidArgumentException]
Could not find package ModuleName in a version matching 2.3.0

2
2

First of all check your third party extension's composer.json file and find required php version, if your current php version not available in "require" then please add latest version "7.2.12" and also add framework version "102.0.*"

"require": {
        "php": "~5.6.0|7.0.2|7.0.4|~7.0.6|~7.1.0|~7.2.12",
        "magento/module-backend": "100.0.*|100.1.*|100.2.*",
        "magento/framework": "100.0.*|100.1.*|101.0.*|102.0.*"
    },

After that please find your third party extension name on /vendor/composer/installed.json file, you can see php version and framework version in this file So please add php version in "require" same as per module's composer.json file

after above changes please run composer update command and let me know if you get any issue.

Thanks

2
  • 2
    You must have PHP 7.2 installed for Magento 2.3 (PHP 7.1.3+ is also supported) Dec 6 '18 at 9:28
  • I have installed PHP 7.2, and temporary remove those module and seems its working fine now, i will install those module later on. Thanks Dec 6 '18 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.