1

I have been trying to find a solution to this error for nearly 2 hours now in vain.

I recently downloaded Magento 2 and set it up in my localhost windows.

When I go to my admin page, the sign in panel which is supposed to display (from tutorials I've watched) isn't displaying, instead I'm only getting this plain color background.

the default store front (localhost/magento/) shows up with the basic header and footer with the message "CMS homepage content goes here."

Has anyone had the same issue/is familiar with this issue? If so, help would be much appreciated.

Thank you,

Tim

enter image description here

11

1 Answer 1

1

It's causing you problem due to you are on windows.

Give a try to below workaround.

Check this issue also reported on Git. Its core bug for windows system.

https://github.com/magento/magento2/issues/19480#issue-386162790

4
  • I tried the code provided above and got: "There has been an error processing your request Exception printing is disabled by default for security reasons." I then tried the code provided in the github link: replacing: (:138) --> $realPath = $this->fileDriver->getRealPath($path); with --> $realPath = str_replace('\', '/', $this->fileDriver->getRealPath($path)); which turned out to work! Thank you both for your help, I really appriciate it! NOTE: I tried combining both to see what would happen and it gave me the first error message.
    – TimothyKA
    Dec 4, 2018 at 5:23
  • Happy to help you. Please give up vote to consider it as right answer So. Other member can take advantage from it.
    – anonymous
    Dec 4, 2018 at 5:24
  • 1
    EDIT: I made a typo in the code that solved the issue: instead of --> "$realPath = str_replace('\', '/', $this->fileDriver->getRealPath($path)); it's --> "$realPath = str_replace('\\', '/', $this->fileDriver->getRealPath($path));"
    – TimothyKA
    Dec 4, 2018 at 5:37
  • 1
    I need 15 reputation to upvote. Once I achieve that feat, I will upvote the solution lol
    – TimothyKA
    Dec 4, 2018 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.