1

Preconditions

source: magento 1.9.3.10

destination: Magento 2.2.6

3rd party extensions installed

Steps to reproduce

php bin/magento migrate:data -r -a vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.10/config.xml

Expected result

data migration

Actual result

Error message

[2018-12-03 23:50:41][INFO][mode: data][stage: data migration][step:        EAV Step]: started
71% [====================>-------] Remaining Time: < 1 sec

[Exception]
Notice: Undefined offset: 150 in /shop/magento/vendor/magento/data-  migration-tool/src/Migration/Step/Eav/Data.php on line 813

Exception trace:
() at /shop/magento/vendor/magento/framework/App/ErrorHandler.php:61
Magento\Framework\App\ErrorHandler->handler() at /shop/magento/vendor/magento/data-migration-tool/src/Migration/Step/Eav/Data.php:813
Migration\Step\Eav\Data->migrateAttributesExtended() at /shop/magento/vendor/magento/data-migration-tool/src/Migration/Step/Eav/Data.php:192
Migration\Step\Eav\Data->perform() at /shop/magento/vendor/magento/data-migration-tool/src/Migration/Mode/AbstractMode.php:79
Migration\Mode\AbstractMode->runStage() at /shop/magento/vendor/magento/data-migration-tool/src/Migration/Mode/Data.php:119
Migration\Mode\Data->runData() at /shop/magento/vendor/magento/data-migration-tool/src/Migration/Mode/Data.php:69
Migration\Mode\Data->run() at /shop/magento/vendor/magento/data-migration-tool/src/Migration/Console/MigrateDataCommand.php:51
Migration\Console\MigrateDataCommand->execute() at /shop/magento/vendor/symfony/console/Command/Command.php:241
Symfony\Component\Console\Command\Command->run() at /shop/magento/vendor/symfony/console/Application.php:843
Symfony\Component\Console\Application->doRunCommand() at /shop/magento/vendor/symfony/console/Application.php:193
Symfony\Component\Console\Application->doRun() at /shop/magento/vendor/magento/framework/Console/Cli.php:104
Magento\Framework\Console\Cli->doRun() at /shop/magento/vendor/symfony/console/Application.php:117
Symfony\Component\Console\Application->run() at /shop/magento/bin/magento:23

I deleted attribute_id 150 from catalog_eav_attibutes as mentioned in issue https://github.com/magento/data-migration-tool/issues/599

but still the same message.

Does anyone have an idea what goes wrong? https://github.com/magento/data-migration-tool/issues/621

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.